NightHauler

Używanie podkładów w edytorze OMSI 2

26 postów w tym temacie

Jak pewnie wszyscy wiecie, w OMSI 2 dostaliśmy możliwość ładowania do mapy danych DEM, a także... no właśnie, używania graficznych podkładów jako pomocy przy tworzeniu map. Przejdźmy więc do sedna:

Co zrobić, by w edytorze wyświetlił nam się podkład?

Krok 1. Podstawową czynnością, którą musimy wykonać, jest podanie edytorowi linku do map, z których będziemy korzystać.

Otwieramy więc plik options.cfg znajdujący się w głównym folderze OMSI. Możemy to zrobić za pomocą dowolnego edytora tekstu. Ja do tego użyję Notepad++, Wy możecie zastąpić go notatnikiem. Zjeżdżamy na sam koniec pliku i odnajdujemy linijkę "[Editor_LinkAerial]", pod nią musimy wstawić owy link do map.

http://www.omnibussimulator.de/forum/index.php?page=Thread&threadID=19259 tutaj mamy kilka przykładowych linków, ja użyłem

http://www.gcmods.de/toquad.php?x=~x&y=~y&z=~z&service=google

Jest to odnośnik do mapy satelitarnej Google. Usunięcie z linku "&service=google" spowoduje użycie map Bing, zaś przez dodanie "&type=roadmap" uzyskamy mapę drogową.

Po wybraniu odpowiedniej mapy i wklejeniu odnośnika do niej w podane miejsce uzyskałem taki kod:

[Editor_LinkAerial]
http://www.gcmods.de/toquad.php?x=~x&y=~y&z=~z&service=google

. Plik options.cfg został już przez nas przygotowany, możemy go zamknąć.

BbjAQ7t.png?1

Krok 2. Krok 2 jest nieobowiązkowy i dotyczy tylko tych, którzy jeszcze nie przekonwertowali swojej mapy do światowych koordynat. By to uczynić odsyłam do poradnika Piotra Sekuły http://omnibussimulator.pl/Temat-Ladowanie-terenu-z-danych-DEM-do-Edytora-Map Część 2, punkty 7-12.

Krok 3. Włączamy edytor map, ładujemy naszą mapę, a następnie w zakładce "tile" zaznaczamy opcję "Use tile aerials" i ustawiamy pożądaną rozdzielczość podkładu (by cokolwiek widzieć polecam 2048 ). Klikamy "Dnl. current tile". Powinno nam wyskoczyć ostrzeżenie o zachowaniu praw własnościowych i informacja o zapisie podkładów do odpowiedniego folderu. Klikamy "OK". W tym momencie edytor na chwilę się zawiesi, gdyż zacznie pobierać podkłady.

UojXec7.png?1

Jeśli wyskoczy nam błąd o treści zbliżonej do "system nie może odnaleźć ścieżki", tworzymy w folderze "maps" folder "aerials", a w nim folder z nazwą katalogu naszej mapy (np. Projekt_Szczecin, New_Map). Powtarzamy krok 3.

QZuCSCw.png?1

Ścieżka do podkładów oraz przykładowe obrazy podkładu.

UWAGA! Jeśli kliknęliśmy "Dnl. current tile", w utworzonym wyżej folderze są obrazki, a mimo to nie widać w edytorze podkładu, musimy odznaczyć i ponownie zaznaczyć opcję "Use tile aerials".

A oto efekt naszej pracy! :)

pNoTTLg.png?1

W razie pytań służę pomocą.

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Mnie to nie wychodzi. Wszystko niby robię jak jest wyżej napisane, a np. w punkcie 3 po kliknięciu na Dnl. current tile nic się nie dzieje...

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Sprawdź, czy w folderze "aerials" masz jakieś obrazki. Jeśli nie , to prawdopodobnie wpisałeś zły adres do serwisu z mapami, nie przekonwertowałeś mapy do koordynat (krok 2) lub OMSI ma po prostu kaprys. W ostatnim przypadku możesz spróbować utworzyć pusty plik jpg w "maps/aerials/NazwaMapy" o nazwie "tile_Xkafla_Ykafla.map.aerial.jpg", gdzie Xkafla i Ykafla to wartości X i Y w górnym rogu edytora w zakładce "Tile".

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

A co, jeśli chcemy działać na kolejnych tile'ach? Skąd wziąć punkt odniesienia by drugi tile był dalszą częścią realnego terenu (w moim przypadku zdjęcia satelitarnego)?

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

O punkt odniesienia zadba edytor, właśnie po to podawaliśmy mu współrzędne naszego położenia. Na każdym kolejnym tile'u analogicznie klikamy "Dnl. current tile", co spowoduje pobranie podkładu dla dalszej części terenu :)

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

A więc tak. Przekonwertowałem mapę (bo nie była) i teraz jak klikam "Dnl. current tile" to najpierw wyskakuje : UojXec7.png?1 . Klikam OK. A po tym wyskakuje " JPEG - Fehler #53. "

Stworzyłem plik aerials/BDG w folderze maps, ale w nim nie ma żadnych zdjęć. Link do mapy google który wkleiłem to jest ten co ty podałeś :

http://www.gcmods.de/toquad.php?x=~x&y=~y&z=~z&service=google

Coś jest źle, czy to po prostu kaprys OMSI2? Bo jeśli tak to poczekam z tworzeniem mapki do wydania łatki... ;(

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Od razu powiem, że w niektórych regionach używanie najwyższej czy nawet 512 px daje Fehlera. Używaj 256px, ale jeśli nie wyjdzie to niestety nie ma rady.

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Gdy użyłem 256 px, to wtedy wyskakuje błąd, że się nie udało ściągnąć podkładu i mam sprawdzić, czy mam poprawny wpis w options.cfg...

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Czy jest możliwość użycia podkładów z map Geoportal? Mapy są dokładne, w moim przypadku nawet dokładniejsze niż Google Maps czy Bing.

Nie wiem tylko co wpisać w pliku options.cfg

Z góry dzięki za pomoc.

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Taka mała uwaga: wydaje mi się, że podkład jest błędnie zeskalowany do rzeczywistości.

Mam mapy geodezyjne z podanymi wymiarami ulic/chodników (szerokosc ulicy, szerokosc chodnika, kąt zakrętu itd).

Przykładowo ulica mająca na mapie geo szerokość 9,5m jest o 1m szersza niż ta pokazywana przez mapy google. Jeśli zwężę ją tak aby dopasować do podglądu to jest problem, aby stworzyć 3 pasową ulicę, na której pojazdy mijają się bez problemu. Pozostawienie wymiaru 9.5m może spowodować, że odległości pomiędzy skrzyżowaniami będą nierzeczywiste.

Druga sprawa, w moim mieście jest dosyć sporych rozmiarów wzniesienie, dookoła którego biegnie droga, wzniesienie również widoczne jest w edytorze po wczytaniu danych DEM, bo dodaniu nakładki google, ulica biegnie po wzniesieniu.

Czy jest jakoś możliwość dobierania skali obrazu mapy google?

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

#970

Z mapami Google jest taki problem, o którym miałem wspomnieć, a w końcu nie wspomniałem - używając skryptu zalinkowanego na pierwszej stronie, obraz przesuwa się nieznacznie na południowy zachód. Dlatego ja osobiście korzystam z map Bing przy Radomiu.

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Daj linka do oficjalnego forum z tym tematem

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Polecam osobiście korzystanie map z Binga. Sprawdzałem u siebie i dla przykładu załadowałem dane z Poznania, na podkładzie z Google Maps nie działała wyższa rozdzielczość niż 256px ("Fehler 53"), czyli beznadziejnie, Bing od razu wczytał z jakością 2Mpx.

Czy ten wpis jest poprawny?

[Editor_LinkAerial]
http://www.gcmods.de/toquad.php?x=~x&y=~y&z=~z&type=roadmap

Robi mi się coś takiego zamiast mapy drogowej:

73128832968868096384.jpg

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Czy jest możliwość utworzenia podkładu w edytorze dla mapy, która była wcześniej robiona (tzn. ma obiekty i spliny), czy wszystko trzeba zaczynać od nowa?

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Szaqql, Dla map binga należy użyć parametru type=road, o czym już Ci napisałem na SB.

Czy jest możliwość utworzenia podkładu w edytorze dla mapy' date=' która była wcześniej robiona (tzn. ma obiekty i spliny), czy wszystko trzeba zaczynać od nowa?

[/quote']

Tak, jest to teoretycznie możliwe, jednak w praktyce bardzo pracochłonne, ponieważ należałoby wtedy zmienić nazwę każdego tile'a, na taką, której używa edytor do określenia położenia geograficznego danego miejsca (niestety nie wiem na jakiej zasadzie opiera się to nazewnictwo).

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Ja mam inny problem. Dodałem linijke z linkiem do options.cfg.

[Editor_LinkAerial]
http://www.gcmods.de/toquad.php?x=~x&y=~y&z=~z

Lecz kiedy próbuje pobrać podkład, wyskakuje mi taki błąd.

http://i58.tinypic.com/13zdehc.gif

Jakieś pomysły?

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

bo link http://www.gcmods.de/toquad.php?x=~x&y=~y&z=~z nie działa od jakiegoś dłuższego czasu? Prowadzi do "Bad Request"


Bo masz błędny link...

u mnie działa:

[Editor_LinkAerial]
http://www.gcmods.de/toquad.php?x=~x&y=~y&z=~z&service=google&hres=1

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Zmienił się wzór linku dający dostęp do map Bing:

http://www.omnibussimulator.de/forum/index.php?page=Thread&postID=511791#post511791

Tak w skrócie to trzeba się zalogować danymi swojego konta Microsoft na https://www.bingmapsportal.com .Jeśli ktoś nie ma musi założyć, a potem uzyskać klucz API ( podstawowy angielski wymagany, ale "po omacku" też da się ogarnąć :P ).W pliku "options.cfg" linijka ma wyglądać tak:

http://www.gcmods.de/toquad.php?x=~x&y=~y&z=~z&apicode=TwojKluczAPI

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Mapy Bing w niektórych miejscach nie są robione z wysoką dokładnością. W moim przypadku zamiast siatki ulic pojawia się znaczek przekreślonego aparacika. Ma ktoś może inne źródła map ?

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

TYLKO rozdzielczość 2048px (niższe rozdzielczości powodują zmniejszenie zdjęcia a nie rozdzielczości)

TYLKO dla osób, które rozpoczynają tworzenie mapy (zdjęcia przesunięte o paredziesiąt metrów względem map google)

http://omsi2.ofpmafia.eu/google_API.php?x=~x&y=~y&z=~z

//poprawka... przesunięcei mapy jest tylko w momencie gdy robiliśmy mapę w Bing a przechodzimy na Google :/

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Witam, przepraszam za odkop ale musiałem. 

Mam taki bląd gdy klikam ten Dnl. current nie to pisze mi taki błąd wszystko w options.cfg zrobiłem wszystko to co jest podane nawet Piotra Sekuły i nie wiem dlaczego mi nie działa zdjęcie:

http://zapodaj.net/6388922fc2ab1.png.html

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jest obecnie jakaś opcja na podkłady w dobrej jakości?

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Tylko zarejestrowani użytkownicy mogą dodawać komentarze

Dodaj konto

Załóż nowe konto. To bardzo proste!


Zarejestruj nowe konto

Zaloguj się

Posiadasz już konto? Zaloguj się tutaj.


Zaloguj się teraz

  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników, przeglądających tę stronę.