kazik2000

Repaint Tool

110 postów w tym temacie

Siema.

Mam problem otoż zrobiłem tak.

otwarłem??:o plik templates\D86_01_BS.bmp w SDK programem Paint.NET przemalowałem cala bleche na czarno zapisałem jako dmp właczam RepaintTool wybieram D86_1.rpc pozniej moja teksture bmp powstaje mi plik DDS wrzucam go do C:\m-r-software\Omsi\Vehicles\MAN_SD202\Texture\Werbung_D86 i tam twoze jeszcze plik cti

***************************************

D86_01_BS

***************************************

[item]

D86_01_BS

farbschema_tex1

D86_01_BS.dds

I cholera nie działa.... :( nie wyświetla mi tej textury w omsi

nie mam siły nawet tego poprawiać..... dałeś popis na całej lini

//edit

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Być może twój plik .cti jest plikiem nazwa.cti.txt jeśli masz włączone w windowsie ukrywanie znanych rozszerzeń. Wtedy OMSI go nie przeskanuje :)

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Mam zrobiony własny plik cti i dodany do istniejącego. wyłączone ukrywanie.

We właściwościach pisze format cti...

ręce opadają :P złośliwość rzeczy martwych :P

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Zacytuję z trzeciego posta:

Dxx_01_MA.bmp - plik biało-czarny - generalnie wszystko co jest czarne zostanie czymś oskryptowane' date=' czyli szyby, numery taborowe, wyświetlacze... Miałem problem z tym, że po repaincie okolice wyświetlacza były beżowe. A to dlatego że obwód ich był pokryty czarnym kolorem w tym pliku. Wystarczyło zmniejszyć "czarność" (dopasować do wymiarów szyby).[/quote']

W skrócie: zamaluj obwódkę na biało - wszystko co jest na czarno nie zostanie pokryte Twoją farbą.

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Ok. Tylko że przy D92 niewidzę takiego pliku. Czy mam go stworzyć w plikach repaint tool

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Mam małe zapytanie,

otóż potrzebuje zmienić podkład pod taborowy - oryginalnie jest on beżowy.

Lub druga opcja by zmienić kolor samego taborowego, wie ktoś jak mógłbym to uczynić?

Pytanie wspiera Administracja portalu.

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Podkład pod numer taborowy...

W pliku (S)Dxx_01_MA.bmp usunąć małe czarne prostokąciki na przodzie i tyle. Weź też pozycje i rozmiar tych prostokątów...

W pliku (S)Dxx_01_BS.bmp używając pozycji i rozmiarów z MA zamaluj te prostokąty wg. własnej potrzeby - jeśli tekstura nie jest reklamą całopojazdową ([OT]błee[/OT]), a czystym malowaniem firmowym... nie musisz.

Tak samo [sichtkarten Kasse] nad drzwiami, logo BVG na boku, obwódki wyświetlaczy, etc.

Kolor taborowego...

Wejdź w <ścieżka>\Vehicles\MAN_SD20x\Model i znajdź plik model_(S)Dxx.cfg odpowiadający twojemu wozowi. Następnie znajdź taki lub podobny wpis na górze pliku:

0
[texttexture_enh]
number
Kennz_DtAlt
64
64
1
0
0
0
3
1

Interesują nas te trzy zera po środku - są to dane RGB (0,0,0 to czarny). Znajdź pasujący Ci kolor oraz zamień po kolei dane: R (czerwień), G (zieleń) i B (niebieski).

Pasuje?

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

A załadowałeś teksturę/wóz od nowa?

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Mi też "za Chiny" nie udaje się zmienić koloru numeru taborowego (w SD81). Zmieniam wartości RGB tam gdzie niby trzeba a numery jak były tak dalej są czarne.

Edit: mam problem również z teksturą "SD81_04.bmp". Chcąc zrobić dobre malowanie musiałem edytować i ten plik (chociażby zmiana kolorów rurek). Ale żeby było mało inwazyjnie zapisałem go pod inną nazwą ("SD81_04new.bmp"), po czym w pliku modelu (oryginalnie "model_SD81.cfg") zamieniłem wszystkie deklaracje tego pliku na nową nazwę. Gra się wysypuje po wybraniu modelu i nie wiem co z tym dalej zrobić. Nigdzie indziej nie ma deklaracji tego pliku więc nie wiem w czym rzecz. Bitmapa jest poprawna bo bez zmiany nazwy działa. Ktoś wie o co może biegać?

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Zapewne tekstura została zamapowana na model 3D pod taką, a nie inną nazwą (wiem, dziwne, skoro była deklaracja w pliku .cfg). Może zrób normalnie - back-up oryginału > nowy plik w starą nazwę > poprawka w config-u.

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

No tak, ale jakbym chciał już udostępnić to że się tak wyrażę - lipa. Nie każdemu np. w SD81 spodoba się nowa kolorystyka, a niektórym nawet jak się pisze, żeby robili kopie zapasowe wielkimi i pogrubionymi literami to i tak nie zrobią, a później pretensje. Zapytam jeszcze na forum oficjalnym.

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Witam.Napiszę tutaj żeby nie zabrudzać forum.A więc tak mam problem z Repaint tool oto ten problem : piszę mi 75 Path/Access to error pomocy :D

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

To jest błąd systemowy, nie programu Repaint Tool.

W którym momencie się on pojawia?

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Pojawia się on kiedy włączam Repainta

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Dla każdego, kto ma problem z kolorem numeru taborowego w MAN-ach

(na przykładzie SD81):

1. Odszukujemy plik konfiguracyjny modelu autobusu (np. model_SD81.cfg) i tworzymy kopię zapasową;

2. Odszukujemy linijki i wg mojego opisu wprowadzamy zmiany:

###################
Text-Texturen:
###################

Wagennummer:

[texttexture]
number
Kennz_DtAlt
64
32
1 - zmieniamy na 0, aby zmiana barw zadziałała
0 - wartość R modelu barw RGB
0 - wartość G modelu barw RGB
0 - wartość B modelu barw RGB

Przykładowo, by uzyskać kolor czerwony ten fragment powinien wyglądać tak:

###################
Text-Texturen:
###################

Wagennummer:

[texttexture]
number
Kennz_DtAlt
64
32
0
255
0
0

3. Zapisujemy plik.

Wartości barw modelu RGB można sprawdzić w każdym programie graficznym, albo na stronie http://www.kurshtml.edu.pl/generatory/kolory.html

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Hmmm... pisałem to wcześniej, to jedna sprawa...

A druga... ostatnio cackałem się z wyświetlaczami w D92 (wiem, nie ta kategoria, ale pominę już to). Okazało się, iż po wpisaniu danych 255,102,0 (oczywiście w osobnych linijkach) wyskoczył mi ciemny purpur... Pomarańcz mi wyszła po bodajże 0,102,255, co jest błękitem... Więc jest to BGR.

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Ok to teraz ja mam problem mianowicie. Załadowałem plik D92_2.rpc do "repaint tola" pozniej załadowałem teksture karoserii w bmp. i kiedy klikam, żeby mi skonwertował to pliku nigdzie niema :/ trzeba jakoś ustawić ścieżkę kopiowania bo za chiny ludowe nie wiem gdzie sie to zapisuje :/

PZDR siroccoxp

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Plik skonwertowany wykonwertuje tam, gdzie jest plik do konwertowania. Wiem, przekonwertowałem :P

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

W jakiś cudowny sposób plik się pojawił w pliku repaint xD ale dobra przynajmniej jakieś podstawy mam więc morze w końcu coś przemaluje. Dzięki Piotrze.

PZDR siroccoxp

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Wiem, że może to się wydawać głupie ale jak usunąć tą "szachownice z tekstur? (w gimpie)

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Tylko zarejestrowani użytkownicy mogą dodawać komentarze

Dodaj konto

Załóż nowe konto. To bardzo proste!


Zarejestruj nowe konto

Zaloguj się

Posiadasz już konto? Zaloguj się tutaj.


Zaloguj się teraz

  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników, przeglądających tę stronę.